当前位置:→ 公式指标网 > 公式解答 > 正文 

    编写要求:

     

    www.gszx.com.cn网解答:

     网友求助:

    请老师写个公式
    通达信软件
    设想:最新一天的交易日,K线图,K线下方显示为1(如图)
    往后数,顺序依次为:1,5,10,20,30,60,120,240,显示周期为任意周期!!
    解答如下:
    如果一定要历史信号,这样
    A:=REF(C,BARSLAST(CURRBARSCOUNT=10));
    B:=CURRBARSCOUNT=5 AND C/A>=0.99 AND C/A<=1.01;
    DRAWICON(B,L*0.99,11);
    DRAWNUMBER(CURRBARSCOUNT<=20,L,CURRBARSCOUNT),COLORYELLOW;
    DRAWNUMBER(CURRBARSCOUNT=10,L,CURRBARSCOUNT),COLORMAGENTA;
    DRAWNUMBER(CURRBARSCOUNT=5,L,CURRBARSCOUNT),COLORMAGENTA;
    D:=BARSLAST(MOD(CURRBARSCOUNT,5)=0);
    E:=C/REF(REF(C,D),1)*100-100;
    F:=ABS(E)<=1 AND D=0 AND CURRBARSCOUNT>=10;
    DRAWICON(F,L*0.99,11);

     

    提示交易天数的公式

     

    互动内容:
    昵称: 验证码:验证码 

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号