当前位置:→ 公式指标网 > 公式解答 > 正文 

    编写要求:

     

    www.gszx.com.cn网解答:

     网友求助:

    薛斯通道1
    {参数n 2 120 13}
    VAR2:=CLOSE*VOL;
    VAR3:=EMA((EXPMA(VAR2,3)/EXPMA(VOL,3)+EXPMA(VAR2,6)/EXPMA(VOL,6)+EXPMA(VAR2,12)/EXPMA(VOL,12)+EXPMA(VAR2,24)/EXPMA(VOL,24))/4,N);
    SUP:1.06*VAR3;
    SDN:VAR3*0.94;
    VAR4:=EXPMA(CLOSE,9);
    LUP:EXPMA(VAR4*1.14,5);
    LDN:EXPMA(VAR4*0.86,5);


    薛斯通道2
    {N 80 120 102,M 2 20 7 }
    AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
    通道1:AA*N/100;
    通道2:AA*(200-N)/100;
    CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
    DD:=DMA(CLOSE,CC);
    通道3:(1+M/100)*DD;
    通道4:(1-M/100)*DD;

     
    解答如下:
    //薛斯通道2 参数 N(80 120 102) M (2 20 7 )
    AA:=MA((2*CLOSE+HIGH+LOW)/4,5);
    通道1:AA*N/100,,color0000ff;
    通道2:AA*(200-N)/100,color00ffff;
    CC:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);
    DD:=DMA(CLOSE,CC);
    通道3:(1+M/100)*DD,colorffff00;
    通道4:(1-M/100)*DD,color00ff00;

     

    薛斯通道1的EXPMA升级后,不显示,改了也没有
     

     

    互动内容:
    昵称: 验证码:验证码 

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号