当前位置:→ 公式指标网 > 公式解答 > 正文 

    编写要求:

     

    www.gszx.com.cn网解答:

     网友求助:

    VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
    买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
    卖盘:=IF((CLOSE > OPEN),(0 - (VAR1 * ((HIGH - CLOSE) + (OPEN - LOW)))),IF((CLOSE < OPEN),(0 - (VAR1 * (HIGH - LOW))),(0 - (VOL / 2))));
    买卖差:=(买盘 + 卖盘);
    STICKLINE((买卖差 < 0),0,买卖差,3,0),COLOR33FF33;
    JX1:=BARSSINCE(买盘);
    JY1:=IF(((121 > JX1) AND (JX1 > 0)),JX1,120);
    JY2:=IF(((4 > JX1) AND (JX1 > 0)),JX1,3);
    VAR30:=MA(VOL,JY2);
    神比:=(买盘 / VAR30);
    鬼比:=(卖盘 / VAR30);
    VAR2:=(HIGH - LOW);
    VAR3:=ABS((OPEN - CLOSE));
    VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
    VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
    VAR6:=((VAR3 / VAR2) * VOL);
    VAR7:=((VAR4 / VAR2) * VOL);
    VAR8:=((VAR5 / VAR2) * VOL);
    VAR9:=IF(((VOL / CAPITAL) > 0.001),1,EXP(ABS(LOG(((VOL / CAPITAL) * 100)))));
    VARA:=(((CLOSE - MA(CLOSE,5)) / MA(CLOSE,5)) * 100);
    VARB:=(((MA(CLOSE,5) > MA(CLOSE,10)) AND (MA(CLOSE,10) > MA(CLOSE,30))) AND (MA(CLOSE,30) > MA(CLOSE,60))); VARC:=((MA(CLOSE,5) < MA(CLOSE,10)) AND (MA(CLOSE,10) < MA(CLOSE,30)));
    VARD:=REF(CLOSE,1);
    VARE:=((SMA(MAX((CLOSE - VARD),0),6,1) / SMA(ABS((CLOSE - VARD)),6,1)) * 100);
    DRAWTEXT(((DATE > 700101) AND CROSS(84,VARE)),HIGH,'■卖出'),COLORF2A3A4;
    VAR40:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),VAR6,买盘) + 买盘) / 2);
    VAR41:=((IF(((VAR7 > VAR6) AND (VAR7 > VAR8)),VAR7,买盘) + 买盘) / 2);
    VAR42:=((IF(((VAR8 > VAR6) AND (VAR8 > VAR7)),VAR8,买盘) + 买盘) / 2);
    VAR50:=((IF((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),VAR6,卖盘) + 卖盘) / 2);
    三日上攻:=MA((((VAR40 + VAR41) + VAR42) / 3),JY2);
    三日下攻:=MA(VAR50,JY2);
    多头:STICKLINE((CLOSE > MA(CLOSE,30)),0,VOL,3,1),COLOR0000FF;
    空头:STICKLINE((CLOSE < MA(CLOSE,30)),0,VOL,3,1),COLOR00FF00;
    STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)),0,VAR6,3,0),COLOR00FFFF;
    STICKLINE((((VAR6 >= VAR7) AND (VAR6 >= VAR8)) AND (CLOSE < OPEN)),0,VAR6,3,0),COLORFF0000;
    STICKLINE(((VAR8 > VAR6) AND (VAR8 > VAR7)),0,VAR8,3,0),COLORFFFFFF;
    STICKLINE(((VAR7 > VAR6) AND (VAR7 > VAR8)),0,VAR7,3,0),COLORFF00FF;
    STICKLINE((VOL > (MA(VOL,5) * 2.5)),0,VOL,2,0);
    STICKLINE((买盘 > 0),买盘,0,2,0),COLOR0000FF;
    上攻均量:=MA(买盘,JY1);
    下攻均量:=MA(卖盘,JY1);
    DRAWTEXT(((((((((VAR7 > VAR6) AND (VARA > 2)) AND (VAR9 > VAR8)) AND (CLOSE > MA(CLOSE,5))) AND (CLOSE > MA(CLOSE,30))) AND (HIGH > MA(CLOSE,60))) AND (VOL > MA(VOL,5))) AND (VAR7 >= MA(VOL,5))),VOL,'▼出货');
    DRAWTEXT(((((((VAR8 > VAR6) AND (VAR8 > VAR7)) AND (VARA < (0 - 2))) AND (CLOSE < MA(CLOSE,30))) AND (VAR8 < (MA(VOL,5) / 2))) AND (MA(VOL,5) < MA(VOL,10))),VOL,'●低进');
    DRAWTEXT((((((VAR6 > (MA(VOL,5) * 2)) AND (VAR6 >= VAR7)) AND (VAR6 >= VAR8)) AND (CLOSE > OPEN)) OR ((VOL > (MA(VOL,5) * 3)) AND VARB)),VOL,'◆强势');
    HSL:=DYNAINFO(37);
    总金额:AMOUNT/100000000,NODRAW;


    VAR11:=AMOUNT/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
    流入亿:IF(CLOSE>OPEN,VAR11*(HIGH-LOW),IF(CLOSE<OPEN,VAR11*((HIGH-OPEN)+(CLOSE-LOW)),AMOUNT/2))/100000000,COLORRED,NODRAW;
    流出亿:IF(CLOSE>OPEN,0-VAR11*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE<OPEN,0-VAR11*(HIGH-LOW),0-AMOUNT/2))/100000000,COLOR00FF00,NODRAW;
    差:(流入亿+流出亿),NODRAW;

    强:=XMA((CLOSE-REF(CLOSE,1))/CLOSE*10,2);
    主力:=EMA(差,1),COLORFF00FF,LINETHICK5;
    差A:3*XMA(XMA(XMA(EMA(强,2),2),2),2),NODRAW;

    净流:3*XMA(XMA(XMA(EMA(差A,1),2),2),2), COLORRED,NODRAW;
    DRAWTEXT(C=C AND CURRBARSCOUNT=10,10,'【网专用指标】'),COLORYELLOW;
    白色红芯建仓:0,COLORWHITE;{白色烛,红芯长,庄家找底在振荡,俺也伺机建点仓。}
    黄色红芯进货:0,COLORYELLOW;{黄色烛红芯长庄家进货强俺也进货。}
    粉色红芯低吸:0,COLORMAGENTA;{粉色烛红芯长庄家高抛低吸操作忙俺也去逐浪}
    蓝色红芯清仓:0,COLORGREEN;{蓝色烛,红芯短,巨量绿尾长,庄家撤退,俺也清仓。}
    量绿蓝烛离场:0,COLORCYAN;{巨量绿,蓝烛长,趋势破,急离场;等着跌,莫手痒。}
    网1:=MA(C,1);网5:=MA(C,5); 网6:=MA(C,6);
    DRAWICON(CROSS(网1,网5),L,1);
    DRAWICON(CROSS(网6,网1),H,2);

     在白色红芯柱做一个选股公式
    解答如下:
    VAR1:=(VOL / (((HIGH - LOW) * 2) - ABS((CLOSE - OPEN))));
    买盘:=IF((CLOSE > OPEN),(VAR1 * (HIGH - LOW)),IF((CLOSE < OPEN),(VAR1 * ((HIGH - OPEN) + (CLOSE - LOW))),(VOL / 2)));
    VAR2:=(HIGH - LOW);
    VAR3:=ABS((OPEN - CLOSE));
    VAR4:=(HIGH - IF((CLOSE > OPEN),CLOSE,OPEN));
    VAR5:=(IF((CLOSE > OPEN),OPEN,CLOSE) - LOW);
    VAR6:=((VAR3 / VAR2) * VOL);
    VAR7:=((VAR4 / VAR2) * VOL);
    VAR8:=((VAR5 / VAR2) * VOL);
    VAR8>VAR6 AND VAR8>VAR7 AND 买盘>0 AND 买盘>VAR8 AND C>MA(C,30);
     

     

     

    互动内容:
    昵称: 验证码:验证码 

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号