当前位置:→ 公式指标网 > 公式解答 > 正文 

    编写要求:

     

    www.gszx.com.cn网解答:

     网友求助:

    A0:=(L+H+C*2)/4;
    A1:EMA(A0,14)COLORBLUE,LINETHICK2;
    A2:=EMA(A0,25)COLORLIBLUE,LINETHICK2;
    A1X:=(A1-REF(A1,1))/REF(A1,1)*100,LINETHICK0;
    A2X:=(A2-REF(A2,1))/REF(A2,1)*100,LINETHICK0;
    出击:PARTLINE(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))),COLORMAGENTA,LINETHICK2;
    逃遁:PARTLINE(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X)))),COLORGREEN,LINETHICK2;
    盈10%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.1,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.1),COLORWHITE,POINTDOT;
    盈20%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.2,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.2),COLORWHITE,POINTDOT;
    盈30%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.3),COLORWHITE,POINTDOT;
    盈40%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.4,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.4),COLORWHITE,POINTDOT;
    盈50%:PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.5,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.5),COLORWHITE,POINTDOT;
    铁:PARTLINE(A1X>=0,A1)COLORffffff,LINETHICK2;
    律:PARTLINE(A1X<0 AND A2X<0,A1)COLORGREEN,LINETHICK2;
    STICKLINE(CROSS(A1X,0),H,L,0,0 ),COLOR9933FF;
    STICKLINE(CROSS(A1X,0),C,O,10,0 ),COLOR0000CC;
    STICKLINE(CROSS(A1X,0),C,O,4,0 ),COLOR0033FF;
    STICKLINE(CROSS(0,A1X),L,H,0,0 ),COLOR66CC33;
    STICKLINE(CROSS(0,A1X),C,O,8,0),COLOR00CC00;
    STICKLINE(CROSS(0,A1X),C,O,4,0),COLOR66FF00;
    MA30:=MA(CLOSE,30);
    MA60:=MA(CLOSE,60);
    周MA30:MA(MA30,5),colorFF00ff,linethick2;
    PARTLINE(周MA30<REF(周MA30,1),周MA30),LINETHICK2,colorgray;
    周MA60:MA(MA60,5),colorFF,linethick2;
    PARTLINE(周MA60<REF(周MA60,1),周MA60),LINETHICK2,colorgray;
    【量H】:=IF((AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100);
    STICKLINE(【量H】=100,L,H,0.8,0),COLORYELLOW;
    STICKLINE(【量H】=100 AND C>=O,C,O,5,1),COLORYELLOW;
    STICKLINE(【量H】=100 AND C<O,C,O,5,0),COLORYELLOW;
    TTJ:=BARSLAST((VOL=HHV(VOL,21)));
    K0:=TTJ=0;
    K1:=SUMBARS(K0,1);
    K2:=SUMBARS(K0,2);
    K3:=SUMBARS(K0,3);
    K4:=SUMBARS(K0,4);
    K5:=SUMBARS(K0,5);
    K6:=SUMBARS(K0,6);
    K7:=SUMBARS(K0,7);
    K8:=SUMBARS(K0,8);
    K9:=SUMBARS(K0,9);
    K10:=SUMBARS(K0,10);
    C1:=REF(C,K1-1);
    AA:STICKLINE(K1<=30,REF(C,K1-1)*1,REF(C,K1-1),10,0),COLORYELLOW;
    MA6:=MA(CLOSE,6);
    MA18:=MA(CLOSE,18);
    MA3:=(3)*(MA18) - (2)*(MA6),LINETHICK1,COLORD39D91;
    MA4:=(3)*(MA6) - (2)*(MA18),LINETHICK2,COLOR87B08B;
    M1:=SUM((EMA((CLOSE + LOW)/(2),2))/(2.98),3),POINTDOT,COLORFFFFFF;
    M2:=EMA(M1,21),COLORFF00FF;
    M30:=MA(CLOSE,30),LINETHICK1,COLORFF0000;
    VAR1:=(2)*(MA((LLV((CLOSE + LOW)/(2),8))*(1.1),13)) - EMA((CLOSE + LOW)/(2),3) - ((CLOSE + LOW)/(2))*(0.1);
    VAR2:=IF(((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5) > 0),(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2))/(10),(((-1))*(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2)))/(10));
    VAR3:=IF((VAR2 > 0),VAR2 - 0,(-1));
    DRAWTEXT(CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8)),(M2)*(1.01),'突破白线'),LINETHICK2,COLORffffff;
    STICKLINE(CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8)),(LOW)*(0.99),(LOW)*(0.95),4,0),COLORffffff; 买:CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8)),LINETHICK0;
    天:COUNT(CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8)),20),COLORRED,LINETHICK0;
     

    解答如下:
    A0:=(L+H+C*2)/4;
    A1:=EMA(A0,14);
    A2:=EMA(A0,25);
    A1X:=(A1-REF(A1,1))/REF(A1,1)*100;
    A2X:=(A2-REF(A2,1))/REF(A2,1)*100;
    出击:=PARTLINE(A1X>=0 AND BARSLAST(CROSS(A1X,0))>0,REF((C+O)/2,BARSLAST(CROSS(A1X,0))));
    逃遁:=PARTLINE(A1X<0 AND BARSLAST(CROSS(0,A1X))>0,REF((C+O)/2,BARSLAST(CROSS(0,A1X))));
    盈10%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.1,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.1);
    盈20%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.2,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.2);
    盈30%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.3,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.3);
    盈40%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.4,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.4);
    盈50%:=PARTLINE(A1X>=0 AND H>=REF(A0,BARSLAST(CROSS(A1X,0)))*1.5,REF((C+O)/2,BARSLAST(CROSS(A1X,0)))*1.5);
    铁:=PARTLINE(A1X>=0,A1);
    律:=PARTLINE(A1X<0 AND A2X<0,A1);
    MA30:=MA(CLOSE,30);
    MA60:=MA(CLOSE,60);
    周MA30:=MA(MA30,5),colorFF00ff,linethick2;
    周MA60:=MA(MA60,5),colorFF,linethick2;
    【量H】:=IF((AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100>100,100,(AMOUNT/C)/(HHV(AMOUNT,21)/HHV(C,21))*100);
    K0:=TTJ=0;
    K1:=SUMBARS(K0,1);
    K2:=SUMBARS(K0,2);
    K3:=SUMBARS(K0,3);
    K4:=SUMBARS(K0,4);
    K5:=SUMBARS(K0,5);
    K6:=SUMBARS(K0,6);
    K7:=SUMBARS(K0,7);
    K8:=SUMBARS(K0,8);
    K9:=SUMBARS(K0,9);
    K10:=SUMBARS(K0,10);
    C1:=REF(C,K1-1);
    MA6:=MA(CLOSE,6);
    MA18:=MA(CLOSE,18);
    MA3:=(3)*(MA18) - (2)*(MA6);
    MA4:=(3)*(MA6) - (2)*(MA18);
    M1:=SUM((EMA((CLOSE + LOW)/(2),2))/(2.98),3);
    M2:=EMA(M1,21),COLORFF00FF;
    M30:=MA(CLOSE,30),LINETHICK1,COLORFF0000;
    VAR1:=(2)*(MA((LLV((CLOSE + LOW)/(2),8))*(1.1),13)) - EMA((CLOSE + LOW)/(2),3) - ((CLOSE + LOW)/(2))*(0.1);
    VAR2:=IF(((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5) > 0),(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2))/(10),(((-1))*(POW((EMA((CLOSE + LOW)/(2),3) - VAR1)*(5),2)))/(10));
    VAR3:=IF((VAR2 > 0),VAR2 - 0,(-1));
    XG:CROSS(VAR3,0) AND ((CLOSE + LOW)/(2) > MA((CLOSE + LOW)/(2),8));
     

     

    互动内容:
    昵称: 验证码:验证码 

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号