当前位置:→ 公式指标网 > 公式解答 > 正文 

    编写要求:

     

    www.guhai.com.cn股海网解答:

    网友求助:

     给力3牛指标 做4个选股公式 , 郑云2009老师
    (选股 1 短牛 ) (选股 2中 牛) ( 选股 3 大牛) ( 选股4 短中大 牛)

     

     

    RSV:=(CLOSE-LLV(LOW,9))/(HHV(HIGH,9)-LLV(LOW,9))*10;
    K:SMA(RSV,3,1);
    D:SMA(K,3,1);
    J:3*K-2*D;
    2,COLORCC6633;5,COLOR996699;

    10,COLOR996699,LINETHICK1;
    VAR1:=C-REF(C,1);
    VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
    MA5:=EMA(C,5);
    MA13:=EMA(C,13);
    UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
    (MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
    (MA5,MA13))+1),0),COLOR0000FF;
    DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS
    (MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS
    (MA13,MA5))+1),0),COLOR00FF00;
    BT:(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
    REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
    STICKLINE(UP,0,0.2,3,0),COLOR0000FF;
    STICKLINE(DOWN,0,0.2,3,0),COLOR00FF00;
    STICKLINE(BT,0,3,2,0),COLOR000088;
    STICKLINE(BT,0,3,1,0),COLOR0000CC;
    STICKLINE(BT,0,3,0.22,0),COLOR0000FF;
    DRAWTEXT(BT,3,'短牛'),COLOR0000FF;
    TJ1:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
    STICKLINE(TJ1,0,2,3,0),COLOR880088;
    STICKLINE(TJ1,0,2,1.5,0),COLORAA00AA;
    STICKLINE(TJ1,0,2,0.8,0),COLORCC00CC;
    STICKLINE(TJ1,0,2,0.2,0),COLORFF00FF;
    DRAWTEXT(TJ1,2,'中牛'),COLORFF00FF;
    HR:=HHV(HIGH,55);
    HRY:=LLV(LOW,55);
    HRY11:=HR*HRY;
    HRY33:=SQRT(HRY11);
    TJ2:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
    STICKLINE(TJ2,0,1,5,0),COLOR008888;
    STICKLINE(TJ2,0,1,2,0),COLOR00AAAA;
    STICKLINE(TJ2,0,1,1,0),COLOR00CCCC;
    STICKLINE(TJ2,0,1,0.2,0),COLOR00FFFF;
    DRAWTEXT(TJ2,1,'大牛'),COLOR00FFFF;
    ST:=REF(UP,1)>REF(UP,2) AND DOWN<REF(UP,1);
    STICKLINE(ST,10,11.05,5,0),COLOR008800;
    STICKLINE(ST,10,11.05,2,0),COLOR00AA00;
    STICKLINE(ST,10,11.05,1,0),COLOR00CC00;
    STICKLINE(ST,10,11.05,0.2,0),COLOR00FF00;

    DRAWICON(BT AND TJ1 AND TJ2,5,25);

    解答如下:

    VAR1:=C-REF(C,1);
    VAR2:=100*EMA(EMA(VAR1,6),6)/EMA(EMA(ABS(VAR1),6),6);
    MA5:=EMA(C,5);
    MA13:=EMA(C,13);
    UP:=DRAWLINE(L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),0);
    DOWN:=DRAWLINE(H=HHV(H,BARSLAST(CROSS(MA5,MA13))+1),HHV(H,BARSLAST(CROSS(MA5,MA13))+1),L=LLV(L,BARSLAST(CROSS(MA13,MA5))+1),LLV(L,BARSLAST(CROSS(MA13,MA5))+1),0);
    HR:=HHV(HIGH,55);
    HRY:=LLV(LOW,55);
    HRY11:=HR*HRY;
    HRY33:=SQRT(HRY11);
    短牛:=(LLV(VAR2,2)=LLV(VAR2,7) AND COUNT(VAR2<0,2) AND CROSS(VAR2,MA(VAR2,2))) AND
    REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1);
    中牛:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HHV(H,21)*0.82;
    大牛:=REF(DOWN,1)<REF(DOWN,2) AND UP>REF(DOWN,1) AND C<HRY33;
    选牛:短牛+中牛+大牛>0;

     

    互动内容:
    昵称: 验证码:验证码 

关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号