当前位置:→ 公式指标网 > 飞狐公式 > 正文 

以下是飞狐指标五星连珠副图源码(无源码的请下载附件导入)

k2:=EMA(c,5),colorffff00;
k3:=EMA(c,10),colorffff00;
k5:=EMA(c,30),colorffff00;kk5:=EMA(indexc,30),colorffff00;

k6:=2*(k2-k5);k7:=2*(k2-k3);k8:=2*(k7+k6),COLORRED;
STICKLINE(CROSS(k8,0),0,50,8,0) ,COLORRED;

k1:=IF(k8>ref(k8,5) and k3<ref(k3,5) ,1,0 ),COLORYELLOW;
k21:=IF(k8>ref(k8,7) and k3<ref(k3,7) ,1,0 ),COLORYELLOW;
k31:=IF(k8>ref(k8,9) and k3<ref(k3,9) ,1,0 ),COLORYELLOW;
k4:=IF(k8>ref(k8,11) and k3<ref(k3,11) ,1,0 ),COLORYELLOW;

        nday := 3;
down := close/llv(low,60)<=1.2;
pma1 := ma(close,2);
pma2 := ma(close,5);
diff :=ema(close,12) - ema(close,26),colorwhite;
dea :=ema(diff,9),colorgreen;
vma1:=ma (vol,2)/100000,colorred;
vma2:=ma(vol,5)/100000,coloryellow;
ppday := barslast(cross(pma1,pma2));
vvday := barslast(cross(vma1,vma2));
MACDday := barslast(cross(diff,dea));
A1:=BARSLAST(ref(cross("macd.diff"(5,12,9),"macd.dea"(5,12,9)),1));
背离、W底、金叉:=ref(c,A1+1)>c and ref("macd.diff"(5,12,9),A1+1)<"macd.diff"(5,12,9) and
cross("macd.diff"(5,12,9),"macd.dea"(5,12,9)),,colorred;

sjcjd:= if((ppday<=nday and vvday<=nday and macdday<=nday ) and (diff<0),1,0);
STICKLINE(sjcjd,50,60,6,0),colorwhite,linethick2;
MACD:= 2*(diff-dea), COLORSTICK;

趋势:=((3*SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1)-2*SMA(SMA((CLOSE-LLV(LOW,27))/(HHV(HIGH,27)-LLV(LOW,27))*100,5,1),3,1)-50)*1.032+50),COLORRED;
Vara2:=(2*CLOSE+HIGH+LOW+OPEN)/5;
Vara3:=LLV(LOW,34);
Vara4:=HHV(HIGH,34);
长趋势:=EMA((Vara2-Vara3)/(Vara4-Vara3)*100,13),color00ff00;
判断底:=SQRT(SQRT(FLOOR(SQRT(MA(1/WINNER(CLOSE)*100,4)/10000))))*5;
Vara5:=CROSS(短趋势,长趋势)AND 长趋势<25;

Vara6:=CROSS(短趋势,长趋势)AND 长趋势<50;
STICKLINE(Vara5,60,70,8,0) ,colorgreen;

XX:=((((CLOSE - MA(CLOSE,34)) / MA(CLOSE,34)) * 100)* 5);
B001:=(((((CLOSE - MA(CLOSE,42)) / MA(CLOSE,42)) ) * 100) * 5);
B002:=(((((CLOSE - MA(CLOSE,67)) / MA(CLOSE,67)) ) * 100) * 5);
B003:=(((XX + B001) / 2) - (B002 ));
B004:=(((0 - 100) * (HHV(HIGH,34) - CLOSE)) / (HHV(HIGH,34) - LLV(LOW,34)));
B005:=(((0 - 100) * (HHV(HIGH,42) - CLOSE)) / (HHV(HIGH,42) - LLV(LOW,42)));
B006:=(((0 - 100) * (HHV(HIGH,72) - CLOSE)) / (HHV(HIGH,72) - LLV(LOW,72)));
B007:=EMA((((B004 + B005) / 2) - B006),6);
B008:=REF(CLOSE,1);

B009:=((((SMA(MAX((CLOSE - B008),0),19,1) / SMA(ABS((CLOSE - B008)),19,1)) * 100) - 50) * 1.25);
B010:=((((SMA(MAX((CLOSE - B008),0),34,1) / SMA(ABS((CLOSE - B008)),34,1)) * 100) - 50) * 1.25);
B011:=((((SMA(MAX((CLOSE - B008),0),72,1) / SMA(ABS((CLOSE - B008)),72,1)) * 100) - 50) * 1.25);
B012:=EMA(((((B009 + B010) / 2) - B011) * 5),6);
B013:=((((0 - 1) * ((B007 + B003) + B012)) / 3) * 1.5);
B014:=B012;
B015:=B013;
B016:=EMA(B012,4);
B017:=B012;
KKM1:=B013;
DPM1:=EMA(B013,4);
多头:=B017,color0000FF;
空头:=KKM1,color00FF00;
多均:=B016;
空均:=DPM1;
B018:=IF(CROSS(B017,KKM1),28,0);
xd:=5 ;
VARX:=B017;
C023:=KKM1;
C024:=B016;
C025:=DPM1;
C026:=WINNER(CLOSE);
W:=(DMA(C026,((VOL / CAPITAL) * 1)) * 100);
HWXWINNER:=W;
XD1:=EMA(W,6);
XWXMH:=XD1;
XD2:=MA(W,14);
庄家控盘:=((HWXWINNER - XWXMH) * 10),COLORSTICK,LINETHICK2;
STICKLINE(cross(多头,空均),80,70,8,0) ,COLORYELLOW;
Varb1:=(2*CLOSE+HIGH+LOW)/4;
Varb2:=LLV(LOW,34);
Varb3:=HHV(HIGH,34);
Varb4:=ma(HIGH,8);
xx1:=EMA((Varb1-Varb2)/(Varb3-Varb2)*100,13);
yy:=EMA(0.667*REF(xx1,1)+0.333*xx1,2) , ;
STICKLINE(CROSS(xx1,20) AND yy<xx1 and Varb4>ref(Varb4,1),80,90,6,0),COLORFF0000;

逃顶:=IF(FILTER(CROSS(YY,XX) AND xx>80 ,3),60,90),COLORFF0000;

飞狐指标五星连珠副图源码


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号