当前位置:→ 公式指标网 > 飞狐公式 > 正文 

以下是飞狐千钧操盘主图指标(无源码的请下载附件导入)

飞狐千钧操盘主图指标

源码

{-----------------------☆功能开关------------------------}
nn0:=SYSPARAM(3)-SYSPARAM(2);
nn:=BARSCOUNT(c)-SYSPARAM(2);
hh1:=(SYSPARAM(4)-SYSPARAM(5))/20;
y0:=BARSCOUNT(c)>=SYSPARAM(2);
vv0:=if(y0=1 and SYSPARAM(1)>=BARSCOUNT(c),v,0);
c1:= if(BETWEEN(c,SYSPARAM(4)-0.0*hh1,SYSPARAM(4)-0.5*hh1),vv0,0);
c2:= if(BETWEEN(c,SYSPARAM(4)-0.5*hh1,SYSPARAM(4)-1.0*hh1),vv0,0);
c3:= if(BETWEEN(c,SYSPARAM(4)-1.0*hh1,SYSPARAM(4)-1.5*hh1),vv0,0);
c4:= if(BETWEEN(c,SYSPARAM(4)-1.5*hh1,SYSPARAM(4)-2.0*hh1),vv0,0);
c5:= if(BETWEEN(c,SYSPARAM(4)-2.0*hh1,SYSPARAM(4)-2.5*hh1),vv0,0);
c6:= if(BETWEEN(c,SYSPARAM(4)-2.5*hh1,SYSPARAM(4)-3.0*hh1),vv0,0);
c7:= if(BETWEEN(c,SYSPARAM(4)-3.0*hh1,SYSPARAM(4)-3.5*hh1),vv0,0);
c8:= if(BETWEEN(c,SYSPARAM(4)-3.5*hh1,SYSPARAM(4)-4.0*hh1),vv0,0);
c9:= if(BETWEEN(c,SYSPARAM(4)-4.0*hh1,SYSPARAM(4)-4.5*hh1),vv0,0);
c10:=if(BETWEEN(c,SYSPARAM(4)-4.5*hh1,SYSPARAM(4)-5.0*hh1),vv0,0);
c11:=if(BETWEEN(c,SYSPARAM(4)-5.0*hh1,SYSPARAM(4)-5.5*hh1),vv0,0);
c12:=if(BETWEEN(c,SYSPARAM(4)-5.5*hh1,SYSPARAM(4)-6.0*hh1),vv0,0);
c13:=if(BETWEEN(c,SYSPARAM(4)-6.0*hh1,SYSPARAM(4)-6.5*hh1),vv0,0);
c14:=if(BETWEEN(c,SYSPARAM(4)-6.5*hh1,SYSPARAM(4)-7.0*hh1),vv0,0);
c15:=if(BETWEEN(c,SYSPARAM(4)-7.0*hh1,SYSPARAM(4)-7.5*hh1),vv0,0);
c16:=if(BETWEEN(c,SYSPARAM(4)-7.5*hh1,SYSPARAM(4)-8.0*hh1),vv0,0);
c17:=if(BETWEEN(c,SYSPARAM(4)-8.0*hh1,SYSPARAM(4)-8.5*hh1),vv0,0);
c18:=if(BETWEEN(c,SYSPARAM(4)-8.5*hh1,SYSPARAM(4)-9.0*hh1),vv0,0);
c19:=if(BETWEEN(c,SYSPARAM(4)-9.0*hh1,SYSPARAM(4)-9.5*hh1),vv0,0);
c20:=if(BETWEEN(c,SYSPARAM(4)-9.5*hh1,SYSPARAM(4)-10.0*hh1),vv0,0);
c21:=if(BETWEEN(c,SYSPARAM(4)-10.0*hh1,SYSPARAM(4)-10.5*hh1),vv0,0);
c22:=if(BETWEEN(c,SYSPARAM(4)-10.5*hh1,SYSPARAM(4)-11.0*hh1),vv0,0);
c23:=if(BETWEEN(c,SYSPARAM(4)-11.0*hh1,SYSPARAM(4)-11.5*hh1),vv0,0);
c24:=if(BETWEEN(c,SYSPARAM(4)-11.5*hh1,SYSPARAM(4)-12.0*hh1),vv0,0);
c25:=if(BETWEEN(c,SYSPARAM(4)-12.0*hh1,SYSPARAM(4)-12.5*hh1),vv0,0);
c26:=if(BETWEEN(c,SYSPARAM(4)-12.5*hh1,SYSPARAM(4)-13.0*hh1),vv0,0);
c27:=if(BETWEEN(c,SYSPARAM(4)-13.0*hh1,SYSPARAM(4)-13.5*hh1),vv0,0);
c28:=if(BETWEEN(c,SYSPARAM(4)-13.5*hh1,SYSPARAM(4)-14.0*hh1),vv0,0);
c29:=if(BETWEEN(c,SYSPARAM(4)-14.0*hh1,SYSPARAM(4)-14.5*hh1),vv0,0);
c30:=if(BETWEEN(c,SYSPARAM(4)-14.5*hh1,SYSPARAM(4)-15.0*hh1),vv0,0);
c31:=if(BETWEEN(c,SYSPARAM(4)-15.0*hh1,SYSPARAM(4)-15.5*hh1),vv0,0);
c32:=if(BETWEEN(c,SYSPARAM(4)-15.5*hh1,SYSPARAM(4)-16.0*hh1),vv0,0);
c33:=if(BETWEEN(c,SYSPARAM(4)-16.0*hh1,SYSPARAM(4)-16.5*hh1),vv0,0);
c34:=if(BETWEEN(c,SYSPARAM(4)-16.5*hh1,SYSPARAM(4)-17.0*hh1),vv0,0);
c35:=if(BETWEEN(c,SYSPARAM(4)-17.0*hh1,SYSPARAM(4)-17.5*hh1),vv0,0);
c36:=if(BETWEEN(c,SYSPARAM(4)-17.5*hh1,SYSPARAM(4)-18.0*hh1),vv0,0);
c37:=if(BETWEEN(c,SYSPARAM(4)-18.0*hh1,SYSPARAM(4)-18.5*hh1),vv0,0);
c38:=if(BETWEEN(c,SYSPARAM(4)-18.5*hh1,SYSPARAM(4)-19.0*hh1),vv0,0);
c39:=if(BETWEEN(c,SYSPARAM(4)-19.0*hh1,SYSPARAM(4)-19.5*hh1),vv0,0);
c40:=if(BETWEEN(c,SYSPARAM(4)-19.5*hh1,SYSPARAM(4)-20.0*hh1),vv0,0);
v1:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c1,nn0),0),2));
v2:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c2,nn0),0),2));
v3:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c3,nn0),0),2));
v4:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c4,nn0),0),2));
v5:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c5,nn0),0),2));
v6:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c6,nn0),0),2));
v7:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c7,nn0),0),2));
v8:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c8,nn0),0),2));
v9:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c9,nn0),0),2));
v10:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c10,nn0),0),2));
v11:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c11,nn0),0),2));
v12:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c12,nn0),0),2));
v13:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c13,nn0),0),2));
v14:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c14,nn0),0),2));
v15:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c15,nn0),0),2));
v16:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c16,nn0),0),2));
v17:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c17,nn0),0),2));
v18:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c18,nn0),0),2));
v19:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c19,nn0),0),2));
v20:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c20,nn0),0),2));
v21:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c21,nn0),0),2));
v22:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c22,nn0),0),2));
v23:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c23,nn0),0),2));
v24:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c24,nn0),0),2));
v25:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c25,nn0),0),2));
v26:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c26,nn0),0),2));
v27:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c27,nn0),0),2));
v28:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c28,nn0),0),2));
v29:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c29,nn0),0),2));
v30:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c30,nn0),0),2));
v31:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c31,nn0),0),2));
v32:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c32,nn0),0),2));
v33:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c33,nn0),0),2));
v34:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c34,nn0),0),2));
v35:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c35,nn0),0),2));
v36:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c36,nn0),0),2));
v37:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c37,nn0),0),2));
v38:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c38,nn0),0),2));
v39:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c39,nn0),0),2));
v40:=STRTONUM(NUMTOSTR(if(ISLASTBAR,sum(c40,nn0),0),2));
av0:=max(v1,max(v2,max(v3,max(v4,max(v5,max(v6,max(v7,max(v8,max(v9,max(v10,max(V11,max(V12,max(V13,max(V14,max(V15,max(V16,max(V17,max(V18,max(V19,max(V20, max(v21,max(v22,max(v23,max(v24,max(v25,max(v26,max(v27,max(v28,max(v29,max(v30,max(v31,max(c32,max(v33,max(v34,max(v35,max(v36,max(v37,max(v38,max(v39,v40)))))))))))))))))))))))))))))))))))))));
FILLRGN(v1/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-0.0*hh1,SYSPARAM(4)-0.5*hh1+0.08),Color00C5FF;
FILLRGN(v2/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-0.5*hh1,SYSPARAM(4)-1.0*hh1+0.08),Color00C5FF;
FILLRGN(v3/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-1.0*hh1,SYSPARAM(4)-1.5*hh1+0.08),Color00C5FF;
FILLRGN(v4/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-1.5*hh1,SYSPARAM(4)-2.0*hh1+0.08),Color00C5FF;
FILLRGN(v5/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-2.0*hh1,SYSPARAM(4)-2.5*hh1+0.08),Color00C5FF;
FILLRGN(v6/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-2.5*hh1,SYSPARAM(4)-3.0*hh1+0.08),Color00C5FF;
FILLRGN(v7/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-3.0*hh1,SYSPARAM(4)-3.5*hh1+0.08),Color00C5FF;
FILLRGN(v8/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-3.5*hh1,SYSPARAM(4)-4.0*hh1+0.08),Color00C5FF;
FILLRGN(v9/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-4.0*hh1,SYSPARAM(4)-4.5*hh1+0.08),Color00C5FF;
FILLRGN(v10/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-4.5*hh1,SYSPARAM(4)-5.0*hh1+0.08),Color00C5FF;
FILLRGN(v11/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-5.0*hh1,SYSPARAM(4)-5.5*hh1+0.08),Color00C5FF;
FILLRGN(v12/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-5.5*hh1,SYSPARAM(4)-6.0*hh1+0.08),Color00C5FF;
FILLRGN(v13/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-6.0*hh1,SYSPARAM(4)-6.5*hh1+0.08),Color00C5FF;
FILLRGN(v14/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-6.5*hh1,SYSPARAM(4)-7.0*hh1+0.08),Color00C5FF;
FILLRGN(v15/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-7.0*hh1,SYSPARAM(4)-7.5*hh1+0.08),Color00C5FF;
FILLRGN(v16/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-7.5*hh1,SYSPARAM(4)-8.0*hh1+0.08),Color00C5FF;
FILLRGN(v17/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-8.0*hh1,SYSPARAM(4)-8.5*hh1+0.08),Color00C5FF;
FILLRGN(v18/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-8.5*hh1,SYSPARAM(4)-9.0*hh1+0.08),Color00C5FF;
FILLRGN(v19/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-9.0*hh1,SYSPARAM(4)-9.5*hh1+0.08),Color00C5FF;
FILLRGN(v20/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-9.5*hh1,SYSPARAM(4)-10.0*hh1+0.08),Color00C5FF;
FILLRGN(v21/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-10.0*hh1,SYSPARAM(4)-10.5*hh1+0.08),Color00C5FF;
FILLRGN(v22/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-10.5*hh1,SYSPARAM(4)-11.0*hh1+0.08),Color00C5FF;
FILLRGN(v23/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-11.0*hh1,SYSPARAM(4)-11.5*hh1+0.08),Color00C5FF;
FILLRGN(v24/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-11.5*hh1,SYSPARAM(4)-12.0*hh1+0.08),Color00C5FF;
FILLRGN(v25/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-12.0*hh1,SYSPARAM(4)-12.5*hh1+0.08),Color00C5FF;
FILLRGN(v26/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-12.5*hh1,SYSPARAM(4)-13.0*hh1+0.08),Color00C5FF;
FILLRGN(v27/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-13.0*hh1,SYSPARAM(4)-13.5*hh1+0.08),Color00C5FF;
FILLRGN(v28/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-13.5*hh1,SYSPARAM(4)-14.0*hh1+0.08),Color00C5FF;
FILLRGN(v29/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-14.0*hh1,SYSPARAM(4)-14.5*hh1+0.08),Color00C5FF;
FILLRGN(v30/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-14.5*hh1,SYSPARAM(4)-15.0*hh1+0.08),Color00C5FF;
FILLRGN(v31/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-15.0*hh1,SYSPARAM(4)-15.5*hh1+0.08),Color00C5FF;
FILLRGN(v32/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-15.5*hh1,SYSPARAM(4)-16.0*hh1+0.08),Color00C5FF;
FILLRGN(v33/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-16.0*hh1,SYSPARAM(4)-16.5*hh1+0.08),Color00C5FF;
FILLRGN(v34/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-16.5*hh1,SYSPARAM(4)-17.0*hh1+0.08),Color00C5FF;
FILLRGN(v35/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-17.0*hh1,SYSPARAM(4)-17.5*hh1+0.08),Color00C5FF;
FILLRGN(v36/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-17.5*hh1,SYSPARAM(4)-18.0*hh1+0.08),Color00C5FF;
FILLRGN(v37/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-18.0*hh1,SYSPARAM(4)-18.5*hh1+0.08),Color00C5FF;
FILLRGN(v38/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-18.5*hh1,SYSPARAM(4)-19.0*hh1+0.08),Color00C5FF;
FILLRGN(v39/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-19.0*hh1,SYSPARAM(4)-19.5*hh1+0.08),Color00C5FF;
FILLRGN(v40/av0>=nn/nn0 and nn>=0,SYSPARAM(4)-19.5*hh1,SYSPARAM(4)-20.0*hh1+0.08),Color00C5FF;

YF_DDI:=(AMOUNT / VOL);
YF_JJ:=((OPEN + CLOSE) / 2);
YF_PJJ:=0;
YF_DDING:=EMA(CLOSE,6);
YF_MMD:=MA(YF_DDING,1);
YF_XXD:=EMA(CLOSE,18);
YF_YYZ:=REF(YF_MMD,1);
YF_XXD1:=REF(YF_XXD,1);
YF_YYZ1:=BARSCOUNT(CLOSE);
YF_TDCG:=IF((YF_YYZ1 = 1),0,(((YF_MMD - YF_YYZ) / YF_YYZ) * 100));
YF_ZFD:=IF((YF_YYZ1 = 1),0,(((YF_XXD - YF_XXD1) / YF_XXD1) * 100));
YF_JSD2:=REF(CLOSE,1);
CLOSE1:=IF((YF_YYZ1 = 1),0,(((CLOSE - YF_JSD2) / YF_JSD2) * 100));
YF_JZDF:=IF((YF_YYZ1 = 1),((CLOSE + OPEN) / 2),YF_YYZ);
YF_DCGJ:=YF_MMD;
JJ0:=YF_YYZ;
JJ1:=REF(YF_MMD,2);
JJ2:=(((YF_DCGJ + JJ0) + JJ1) / 3);
JJ02:=(((ABS((YF_DCGJ - JJ2)) + ABS((JJ0 - JJ2))) + ABS((JJ1 - JJ2))) / 3);
SS:=REF(YF_TDCG,1);
YF_ZFD1:=REF(YF_TDCG,2);
YF_ZFD2:=IF((YF_YYZ1 < 3),0,((JJ02 / YF_DCGJ) * 100));
YF_DHPXS:=IF((YF_YYZ1 < 3),0,IF((((YF_TDCG < 0) AND (SS < 0)) AND (YF_ZFD1 < 0)),(0 - 1),1));
SS:=REF(YF_TDCG,1);
YF_YZFZ:=IF((((YF_YYZ1 > 11) AND (SS < 0)) AND (YF_TDCG > 0)),1,0);
YF_JSD21:=BARSLAST((YF_YZFZ = 1));
YF_JSD:=REF(YF_JSD21,1);
A:=IF((((YF_YYZ1 > 11) AND (SS < 0)) AND (YF_TDCG > 0)),(YF_JSD + 1),YF_JSD);
YF_PJJ:=IF((((YF_YYZ1 > 11) AND (SS > 0)) AND (YF_TDCG < 0)),1,0);
YF_JSD11:=YF_JZDF;
DMRJ:=YF_JZDF;
DMCJ:=IF(((YF_YYZ1 > 11) AND (YF_JSD11 < OPEN)),OPEN,YF_JZDF);
YF_DMRJ:=IF(((YF_YYZ1 > 11) AND (DMRJ > OPEN)),OPEN,YF_JZDF);
YF_DMCJ:=0;
YF_DCG1:=REF(YF_JZDF,1);
YF_BDF5:=IF(((((YF_TDCG > 0.5) AND ((YF_ZFD2 > 0.215) OR (LOW > YF_JZDF))) AND (CLOSE >= OPEN)) AND ((CLOSE >= 200) OR ((CLOSE < 200) AND (CLOSE1 < 11)))),1,0);
YF_DMR:=IF((((YF_TDCG < (0 - 0.3)) AND ((YF_ZFD2 > 0.2) OR (HIGH < YF_JZDF))) AND ((OPEN >= CLOSE) OR (CLOSE1 < (0 - 1)))),1,0);
YF_DKS1:=BARSSINCE(YF_BDF5);
YF_TDMR:=BARSSINCE(YF_DMR);
YF_DMR:=(YF_DMR OR (BARPOS = 1));
YF_DCGJ1:=((COUNT(YF_BDF5,BARSLAST(YF_DMR)) = 1) AND YF_BDF5);
YF_DMRBUY:=((COUNT(YF_DMR,BARSLAST(YF_BDF5)) = 1) AND YF_DMR);
YF_DMCSELL:=BARSLAST(YF_DMRBUY);
YF_DCG10:=BARSLAST(YF_DCGJ1);
YF_DCG11:=((SUM(YF_DMRBUY,YF_DCG10) = 0) * YF_DCG10);
YF_DCGREAL:=REF(DMCJ,YF_DCG11);
YF_DMRJ11:=REF(YF_DCGREAL,1);
YF_DMRJ1:=IF((YF_DCGJ1 = 1),(((CLOSE - DMCJ) / DMCJ) * 100),(((YF_DMRJ - YF_DMRJ11) / YF_DMRJ11) * 100));
YF_DCG:=IF((((YF_DCG11 = 0) AND (YF_DCGJ1 = 0)) AND (YF_DMRBUY = 0)),0,YF_DMRJ1);
短买入:=YF_DCGJ1,LINETHICK0,Color00FFFF;
短卖出:YF_DMRBUY,LINETHICK0,ColorFF00FF;
短持股:YF_DCG11,LINETHICK0,ColorFFFF00;
短持股1:=YF_DCG;
AMB:=CROSS(c,MA(c,26));
AMC:=CROSS(MA(c,26),c);
短本次收益:=IF((短买入 = 1),YF_DCGREAL,IF(((短持股 <> 0) OR (短卖出 = 1)),YF_DMRJ11,0));
短买价:=IF((短卖出 = 1),YF_DMRJ,0);
STICKLINE((短买入 = 1),OPEN,CLOSE,8,0),colorFF99FF;
STICKLINE((短买入 = 1),OPEN,CLOSE,6,0),colorFF00FF;
STICKLINE((短买入 = 1),OPEN,CLOSE,4,0),color9900FF;
STICKLINE((短买入 = 1),OPEN,CLOSE,2,0),colorFF;
STICKLINE((短持股 > 0),OPEN,CLOSE,0,0),colorFFBBFF;
STICKLINE((短持股 > 0),OPEN,CLOSE,8,0),colorFF00FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,7,0),colorFF22FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,6,0),colorFF44FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,5,0),colorFF66FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,4,0),colorFF88FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,3,0),colorFF99FF;
STICKLINE((短持股 > 0),OPEN,CLOSE,2,0),colorFFAAFF;
STICKLINE((短持股 > 0),OPEN,CLOSE,1,0),colorFFBBFF;
STICKLINE((短卖出 = 1),OPEN,CLOSE,0,0),colorFF00;
STICKLINE((短卖出 = 1),OPEN,CLOSE,8,0),color8800;
STICKLINE((短卖出 = 1),OPEN,CLOSE,7,0),color9900;
STICKLINE((短卖出 = 1),OPEN,CLOSE,6,0),colorAA00;
STICKLINE((短卖出 = 1),OPEN,CLOSE,5,0),colorBB00;
STICKLINE((短卖出 = 1),OPEN,CLOSE,4,0),colorCC00;
STICKLINE((短卖出 = 1),OPEN,CLOSE,3,0),colorDD00;
STICKLINE((短卖出 = 1),OPEN,CLOSE,2,0),colorEE00;
STICKLINE((短卖出 = 1),OPEN,CLOSE,1,0),colorFF00;
VERTLINE(AMB),LINETHICK1,Color00A8FF;
VERTLINE(AMC),LINETHICK1,ColorFFFF00;
DRAWICON((短买入 = 1),LOW,6),ALIGN1;
DRAWICON((短卖出 = 1),HIGH,5),ALIGN2;
短操盘状态:IF((短买入 = 1),1,IF((短持股 > 0),2,IF((短卖出 = 1),9,0))),LINETHICK0,Color0089FF;
中线止损价:=EMA(CLOSE,26);
中线止赢价:=中线止损价*1.8;

fc:if(c>=1 and c<10,INTPART(c*10)/10,if(c>=10 and c<100,INTPART(c),if(c>=100,INTPART(c/10)*10,c)));
m5:=ma(fc,5); if(m5>=1 and m5<10,INTPART(m5*10)/10,if(m5>=10 and m5<100,INTPART(m5),if(m5>=100,INTPART(m5/10)*10,c)));
m10:=ma(fc,10);if(m10>=1 and m10<10,INTPART(m10*10)/10,if(m10>=10 and m10<100,INTPART(m10),if(m10>=100,INTPART(m10/10)*10,c)));
m20:=ma(fc,20);if(m20>=1 and m20<10,INTPART(m20*10)/10,if(m20>=10 and m20<100,INTPART(m20),if(m20>=100,INTPART(m20/10)*10,c)));

AA:=VOL/((HIGH-LOW)*2-ABS(CLOSE-OPEN));
主动买盘:=IF(CLOSE>OPEN,AA*(HIGH-LOW),IF(CLOSE
主动卖盘:=IF(CLOSE>OPEN,AA*((HIGH-CLOSE)+(OPEN-LOW)),IF(CLOSE
B:=主动买盘-主动卖盘;
五日:=SUM(B,5);
十日:=SUM(B,10);
十五日:=SUM(B,15);
DRAWTEXTEX(c,1,820,950,'中线止赢:'),ColorFFFF00;
DRAWTEXTEX(c,1,930,950,NUMTOSTR(中线止赢价,2)+'元'),ColorFFFF00;
DRAWTEXTEX(c,1,620,950,'中线止损:'),Color00FF00;
DRAWTEXTEX(c,1,740,950,NUMTOSTR(中线止损价,2)+'元'),Color00FF00;
DRAWTEXTEX(c,1,20,880,'主动买盘:'),Color0000FF;
DRAWTEXTEX(c,1,160,880,NUMTOSTR((主动买盘),2)+''),Color0000FF;
DRAWTEXTEX(c,1,20,950,'主动卖盘:'),Color00FF00;
DRAWTEXTEX(c,1,160,950,NUMTOSTR((主动卖盘),2)+''),Color00FF00;
DRAWTEXTEX(c,1,340,880,'五日增减:'),Color00FFFF;
DRAWTEXTEX(c,1,480,880,NUMTOSTR((五日),2)+''),Color00FFFF;
DRAWTEXTEX(c,1,620,880,'十日增减:'),Color00FFFF;
DRAWTEXTEX(c,1,740,880,NUMTOSTR((十日),2)+''),Color00FFFF;
DRAWTEXTEX(c,1,340,950,'十五日增减:'),Color00FFFF;
DRAWTEXTEX(c,1,480,950,NUMTOSTR((十五日),2)+''),Color00FFFF;

{鹏博F10【十大流通股东】}
wa:=F10FIND('【十大流通股东】:',1000);
IF wa<0 THEN EXIT;//没找到退出
wb:=F10FIND(' 1│',wa);
u1:=F10TEXT(wb-1,70);
u2:=F10TEXT(F10FIND('  2│',wb),70);
u3:=F10TEXT(F10FIND('  3│',wb),70);
u4:=F10TEXT(F10FIND('  4│',wb),70);
u5:=F10TEXT(F10FIND('  5│',wb),70);
u6:=F10TEXT(F10FIND('  6│',wb),70);
u7:=F10TEXT(F10FIND('  7│',wb),70);
u8:=F10TEXT(F10FIND('  8│',wb),70);
u9:=F10TEXT(F10FIND('  9│',wb),70);
u10:=F10TEXT(F10FIND(' 10│',wb),70);
a5:=sysparam(5);a0:=(sysparam(4)-sysparam(5))/20;
DRAWTEXTEX(c,1,10,0,u1),Color00FF00;
DRAWTEXTEX(c,1,10,80,u1),Color00FF00;
DRAWTEXTEX(c,1,10,160,u2),Color00FF00;
DRAWTEXTEX(c,1,10,240,u3),Color00FF00;
DRAWTEXTEX(c,1,10,320,u4),Color00FF00;
DRAWTEXTEX(c,1,10,400,u5),Color00FF00;
DRAWTEXTEX(c,1,10,480,u6),Color00FF00;
DRAWTEXTEX(c,1,10,560,u7),Color00FF00;
DRAWTEXTEX(c,1,10,640,u8),Color00FF00;
DRAWTEXTEX(c,1,10,720,u9),Color00FF00;

飞狐千钧操盘主图指标





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号