当前位置:→ 公式指标网 > 大智慧公式 > 正文 

以下是大智慧BS买卖一目了然公式(无源码的请下载附件导入)

大智慧BS买卖一目了然公式

a:="STSFunc@CALSTSL";
R1:="STSFunc@STS_RISK1";
R2:="STSFunc@STS_RISK2";
S1:="STSFunc@STS_STS1";
S2:="STSFunc@STS_STS2";
TBS:="STSFunc@STS_STSBS";
DN:="STSFunc@STS_STSDN";
UP:="STSFunc@STS_STSUP";

压力位:UP,linethick0,color0000ff,PRECIS2;
支撑位:DN,linethick0,color00ff00,PRECIS2;
警示位:IF(R1<>0,ABS(R1),IF(R2<>0,ABS(R2),0)),linethick0,colorff00ff,PRECIS2;
红轨道:MA(MA(CLOSE,3),1),LINETHICK2,COLOR0000FF;
绿轨道:MA(MA(CLOSE,3),3),LINETHICK2,COLOR00FF00;

MA18:MA(CLOSE,18),colorFFFFff,PRECIS2;
MA34:MA(CLOSE,34),color00FFff,PRECIS2;

DRAWLINE(UP>0,UP,UP<>REF(UP,1) OR C=DYNAINFO(7),REF(ABS(UP),1),0),dotline,color0000ff,LINETHICK1;
DRAWLINE(DN>0,DN,DN<>REF(DN,1) OR C=DYNAINFO(7),REF(ABS(DN),1),0),dotline,color00ff00,LINETHICK1;
DRAWLINE(UP<0,-UP,UP<>REF(UP,1) OR C=DYNAINFO(7),REF(ABS(UP),1),0),color0000ff;
DRAWLINE(DN<0,-DN,DN<>REF(DN,1) OR C=DYNAINFO(7),REF(ABS(DN),1),0),color00ff00;
DRAWLINE(R1>0,R1,R1<>REF(R1,1) OR C=DYNAINFO(7),REF(ABS(R1),1),0),dotline,colorEE88ff;
DRAWLINE(R2>0,R2,R2<>REF(R2,1) OR C=DYNAINFO(7),REF(ABS(R2),1),0),dotline,colorEE88ff;
DRAWLINE(R1<0,-R1,R1<>REF(R1,1) OR C=DYNAINFO(7),REF(ABS(R1),1),0),colorEE88ff;
DRAWLINE(R2<0,-R2,R2<>REF(R2,1) OR C=DYNAINFO(7),REF(ABS(R2),1),0),colorEE88ff;

drawbmp(TBS=1,l*0.96,'STSbuy1.bmp'),align1,valign0;
drawbmp(TBS=-1,h*1.07,'STSsell1.bmp'),align1,valign0;
drawbmp(S2=14,l*0.94,'STSbuy.bmp'),align1,valign0;
drawbmp(S2=-14,h*1.09,'STSsell.bmp'),align1,valign0;

drawtext(S1>0,L,STR(S1)),color00FF00,LINETHICK1,align1,valign0;
drawtext(S1<0,H*1.03,STR(-S1)),color00FF00,LINETHICK1,align1,valign0;
drawtext(S2>0 and S2<13,l*0.97,STR(S2)),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2<0 and S2>-13,H*1.06,STR(-S2)),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=13,l*0.97,'+'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=14,l*0.97,'13'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=-13,h*1.06,'+'),color0000FF,LINETHICK1,align1,valign0;
drawtext(S2=-14,h*1.06,'13'),color0000FF,LINETHICK1,align1,valign0;

b:="LTFunc6@FORLT2";
s11:="LTFunc6@LT_S1";
hs:="LTFunc6@LT_HS";
ls:="LTFunc6@LT_LS";
p1:="LTFunc6@LT_P1";
upp:="LTFunc6@LT_UPP";
udd:="LTFunc6@LT_UDD";

d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s11=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');
tr1:=ifs(s11=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s11=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';

bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+'买卖点决策系统提示\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2.短线:'+tr3+tr1+'\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+tr4;
drawflagtext(1,fb,bs);

STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;

STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;

drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;

drawbmp(s11=1 and ref(s11,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s11=0 and ref(s11,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
总股本:=FINANCE2(35) ;
流通股:=FINANCE2(37);
限售A股:=FINANCE2(41);
每股收益:=FINANCE2(3);
市盈率:=DYNAINFO(39);
每股公积金:=FINANCE2(7);
所属板块:=BKNAME;
DRAWTEXTABS(12,14, '所属板块: '+所属板块);
DRAWTEXTABS(12,27,'每股收益: '+NUMTOSTRN(每股收益,3)+'元 利润增长:'+FINANCE2(10)+'% 市盈率:'+NUMTOSTRN(市盈率,1)+'倍 '+' 每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),coloryellow;
DRAWTEXTABS(12,40,'总 股 本: '+NUMTOSTRN(总股本/10000,2)+'亿股'+' 流通A股:'+NUMTOSTRN(流通股/10000,2)+'亿股'+' 限售A股:'+NUMTOSTRN(限售A股/10000,2)+'亿股');


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号