当前位置:→ 股票公式指标网 > 大智慧公式 > 正文 

以下是大智慧新版中的指标一二(原版,原码)(无源码的请下载附件导入)

大智慧新版中的指标一二(原版,原码)

一、跳空缺口:

{向下跳空缺口}
I1:=0;
flag1:=0;
while I1<BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2)
DO  
        IF REF(H,I1)<REF(L,I1+1) AND REF(L,I1+1)>HHV(H,I1+1)
           THEN   BEGIN     FLAG1:=1;
                            S1:=I1;
                            I1:=BARSLAST(DISPSTATUS=1);                        
                  END
        ELSE  I1:=I1+1;            
   STICKLINE(FLAG1,REF(L,S1+1),HHV(H,S1+1),(s1+1)*20,0),ColorC0C0C0,ALIGN1,LAYER7;
  DRAWTEXT(flag1,REF(L,s1+1),NUMTOSTRN(ref(l,s1+1),2)+'-'+NUMTOSTRN(hhV(h,S1+1),2)),ALIGN2,COLORgreen;

{向上跳空缺口}
I:=0;
flag:=0;
while I<BARSLAST(DISPSTATUS=1)-BARSLAST(DISPSTATUS=2)
DO  
        IF REF(L,I)>REF(H,I+1) AND REF(H,I+1)<LLV(LOW,I+1)
           THEN   BEGIN     FLAG:=1;
                            S:=I;
                            I:=BARSLAST(DISPSTATUS=1);                        
                  END
        ELSE  I:=I+1;            
   STICKLINE(FLAG,REF(h,S+1),LLV(LOW,S+1),20*(s+1),500),ColorC0C0C0,ALIGN1,LAYER7;
DRAWTEXT(FLAG,REF(H,s+1),NUMTOSTRN(ref(h,s+1),2)+'-'+NUMTOSTRN(LLV(LOW,S+1),2)),ALIGN2,COLORred;

 


二、封板率

rd:=REQSE( 'MARKETTREND_MIN_FBL_SH000001','/markettrend/index/min?obj=SH000001&field=ShiJian,ZuiXinJiaDengYuZhangTingJiaShu,ZuiGaoJiaDengYuZhangTingJiaShu&output=pb&sub=1',1002 );

股票数:=stkindi('SH000001','涨跌家数.上涨家数#MIN1')+stkindi('SH000001','涨跌家数.下跌家数#MIN1')+stkindi('SH000001','涨跌家数.平盘家数#MIN1')+stkindi('SZ399001','涨跌家数.上涨家数#MIN1')+stkindi('SZ399001','涨跌家数.下跌家数#MIN1')+stkindi('SZ399001','涨跌家数.平盘家数#MIN1');
封板家数:FINDSE( 'MARKETTREND_MIN_FBL_SH000001','ZuiXinJiaDengYuZhangTingJiaShu'),colorred,linethick0;
触及涨停:FINDSE( 'MARKETTREND_MIN_FBL_SH000001','ZuiGaoJiaDengYuZhangTingJiaShu'),color4169E1,linethick0;
rd2:=REQSE( 'MARKETTREND_MIN_FBL_SZ399001','/markettrend/index/min?obj=SZ399001&field=ShiJian,ZuiXinJiaDengYuZhangTingJiaShu,ZuiGaoJiaDengYuZhangTingJiaShu&output=pb&sub=1',1002 );
打开家数:触及涨停-封板家数,precis0,colorFF5252,linethick0;
封板率:封板家数/触及涨停*100;
partline(封板率,封板率<50,rgb(0,255,0),封板率>=50 and 封板率<60,rgb(255,255,255),封板率>60,rgb(255,0,0));
强弱系数:封板家数/股票数*10000,linethick0;
70,dotline,colorred;
60,dotline,colorwhite;
50,dotline,colorgreen;


附件大小:unknow

下载统计:


关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © 铭网科技,All Rights Reserved. 湘ICP备09016573号-3
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号