当前位置:→ 公式指标网 > 大智慧公式 > 正文 

以下是大智慧超牛MACD指标公式(无源码的请下载附件导入)

 {超牛MACD}源码

 

DIFF:EMA(CLOSE,12)-EMA(CLOSE,26);

DEA:EMA(DIFF,9);

MACD:2*(DIFF-DEA),LINETHICK0;

tj:=MACD>REF(MACD,1) AND MACD>0;

连续走强:count(tj,9)-count(tj,3)=6,LINETHICK0,COLOR0030FF;{天}

强势回调:count(tj,7)-count(tj,3)=4,LINETHICK0,COLOR0030FF;{天}

连续走弱:count(tj,9)-count(tj,5)=4,LINETHICK0,COLOR00FF30;{天};

连续反弹:count(tj,5)-count(tj,3)=2,LINETHICK0,COLOR00FF30;{天};

 

STICKLINE(MACD>=0,MACD,0,4,1),COLORF00FF0;

STICKLINE(MACD<0,MACD,0,4,1),COLORWHITE;

 

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,4.5,0 ),COLOR00CCFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,3,0 ),COLOR00DDFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,2,0 ),COLOR00EEFF;

STICKLINE(MACD<REF(MACD,1)AND MACD>0,0,MACD,0.55,0 ),COLOR00FFFF;

 

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,4,0 ),COLOR0022CC;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,3 ,0 ),COLOR0033DD;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,2 ,0 ),COLOR0044EE;

STICKLINE(MACD>=REF(MACD,1)AND MACD>0,0,MACD,0.55 ,0 ),COLOR0055FF;

 

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,4.5,0 ),COLORCC22BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,3,0 ),COLORDD33BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,2,0 ),COLOREE44BB;

STICKLINE(MACD>REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFF55BB;

 

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,4.5,0 ),COLORFFCC22;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,3 ,0 ),COLORFFDD33;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,2 ,0 ),COLORFFEE44;

STICKLINE(MACD<=REF(MACD,1)AND MACD<0,0,MACD,0.55 ,0 ),COLORFFFF55;

 

IF(DIFF<0,DIFF,0),COLORRED,LINETHICK1;

IF(DIFF<0,0,DIFF),COLORYELLOW,LINETHICK1;

IF(DIFF<DEA,DIFF,DEA),COLOR00FF00,LINETHICK1;

IF(DIFF>DEA,DEA,DEA),COLORBLUE,LINETHICK1;

低位金叉:=CROSS(DIFF,DEA) AND DIFF<-0.1;

STICKLINE(低位金叉,0,-0.10,12,0),COLORYELLOW;

DRAWTEXT(低位金叉,-0.05,' 低位金叉'),COLORYELLOW;

JCCOUNT:=COUNT(CROSS(DIFF,DEA),BARSLAST(DEA>=0));

二次金叉:=CROSS(DIFF,DEA) AND DEA<0 AND COUNT(JCCOUNT=2,21)=1;

STICKLINE(二次金叉,0,-0.10,12,0),COLORFF00FF;

DRAWICON(二次金叉,DEA*1.04,13) ;

DRAWTEXT(二次金叉,-0.08,' 二次金叉'),COLORFF00FF;

A11:=BARSLAST(REF(CROSS(DIFF,DEA),1));

底背离:=REF(CLOSE,A11+1)>CLOSE AND DIFF>REF(DIFF,A11+1) AND CROSS(DIFF,DEA);

STICKLINE(底背离,0,0.13,12,0),COLORRED;

DRAWTEXT(底背离,DEA,' 底背离'),COLORRED;

A22:=BARSLAST(REF(CROSS(DEA,DIFF),1));

顶背离:=REF(CLOSE,A22+1)<CLOSE AND REF(DIFF,A22+1)>DIFF AND CROSS(DEA,DIFF);

DRAWTEXT(顶背离,DEA,' 顶背离'),COLORGREEN;

A1:=DIFF<0 AND DEA<0;

A2:=A1>REF(A1,1);

A3:=BARSLAST(A2);

A4:=COUNT(DEA>0 AND DIFF>0,A3)=0;

A5:=CROSS(DIFF,DEA);{金叉}

A6:=BARSLAST(A5);

A7:=REF(A6,A6+1)+A6;

A8:=(DIFF+DEA)/2;

A9:=(HIGH+LOW)/2;

A10:=A5 AND A7<A3 AND A4 AND A8>REF(A8,A7) AND A9<REF(A9,A7) AND MACD>0;

DRAWTEXT(A10,DIFF*0.95,'★金叉介入'),COLORYELLOW;

大智慧超牛MACD指标公式





关于我们 - 联系我们 - 广告合作 - 下载声明 - 网站帮助 - 友情链接 - 网站地图 - RSS订阅 - TOP
Copyright © gszx.com.cn™,All Rights Reserved.ICP备案号:湘ICP备09016573号
股票公式,股票指标,股票软件,股票知识
股票公式,股票指标,股票软件,股票知识湘公网安备43108102000039号